Как зарезервировать ip адрес на dhcp сервере mikrotik

Как зарезервировать ip адрес на dhcp сервере mikrotik

Как зарезервировать ip адрес на dhcp сервере mikrotik

Секреты настройки
файрвола через

Устройство не отображается на dhcp-сервере.

Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку «Действия до настройки роутера».
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.

Возник следующий вопрос. Вопрос на самом деле более «комплексный», нежели название темы. Суть вопроса — понять, какие данные должны отображаться в разделе leases dhcp — сервера и в ARP таблице.

Роутер: RB3011uias.
Прошивка: 6.46 (stable).

1) Есть dhcp — сервер с подсетью 192.168.1.0/24, с пулом адресов 192.168.1.51-192.168.1.250 (ip с 2 — 50 заняты камерами).

2) Все устройства в локальной сети (компы, принтеры, нас, точки и т.п.) получают Ip адрес динамически, т.е. ни на каких устройствах (почти) я статик не прописываю. Чтобы сделать статичные ip устройствам, которым мне это нужно сделать, я делаю с помощью «make static» во вкладке leases.
На этом этапе появляется первый вопрос. В чем разница «make static» во вкладке leases от «make static» в ARP? Если я сделал статик в leases, то в ARP запись все равно остается динамической, что логично. Нужно ли проделывать данную операцию и в ARP помимо leases, или в leases этого достаточно?
По факту работает все ок и так, но вдруг правильнее будет сделать и там и там?

3) Вопрос, который ближе к заголовку темы. У меня есть один принтер, которому статичный ip я прописал на самом устройстве. Так вот, этот принтер (mac + ip) не отображается не на dhcp — сервере в leases, не в ARP. Это нормально? В ARP — то по идее должно же отображаться. При этом, если, например, я открываю админку какой — нибудь wifi — точки (которые параллельно висят, и к принтеру прямого отношения не имеют), в которых так же можно посмотреть список устройств в локальной сети, там этот принтер прекрасно отображается (mac+ip, который я указал на принтере, + модель сама подтянулась). В чем может быть проблема?

4) Последний вопрос. Если, например, я, все же, присваиваю статичные ip — адреса непосредственно на устройствах. В этом случае по идее мне нужно добавлять запись в leases dhcp — сервера / в ARP? Работает — то оно, само собой, и без добавления. Но может же быть такое, что если, скажем, я выключу данное устройство, и dhcp — сервер по итогу присвоит этот Ip автоматом другому. При включении этого устройства получается, возникнет конфликт.
Если же добавить статик и на самом устройстве, и добавить запись в Leases (mac+ip), то это запись висит в режиме waiting, как бы не видя, что это устройство уже подключено с этим ip и работает.

Спасибо за помощь.

Очень много у Вас суеты по DHCP

1) DHCP — всё что он делает, раздаёт, всё в нём и отображается. Всё что он не делает и
не знает, значит в нём это и не будет отображаться.
1.1) у DHCP есть ряд галочек которые позволяют начинающим подстраховаться,
опять же есть галочка контролирующая конфликты. Так что надо просто правильно
настраивать DHCP
1.2) чтобы DHCP был в актуальном состоянии, чтобы адресация была навиду (так скажем),
не делайте длинной аренды адреса, от 3х до 10 часов оптимально, более не надо, лучше пусть клиент
часто и периодически запрашивает адрес, серверу DHCP это не проблема (если конечно
клиентов не 300-500 штук), и актуальность будет перед глазами.

2) Всё что статично задано — значит надо помнить, использовать ДНС, использовать записи,
и/или также иногда смотреть ARP-таблицу. DHCP знать это не надо (в целом).

3) Я не усложняю задачу как Вы делаете, беру сеть, обычно и в конце и в начале делаю
резерв (10-20 адресов) и всё. То есть есть пул (сеть), скажем 192.168.10.0/24, значит
про запас оставляю с 10.1-по-10.20, и с 10.240-по-10.254.
То есть я эти адреса в пуле не объявляю, и DHCP туда не лезет. Всё.

4) Если Вы так заморачиваетесь с правильностью, то я был Неприятно расстроен, что
Вы хотите красиво сделать и настроить DHCP, но в тоже время, Ваш роутер имеет конфиг пре-заводской,
а понял я по слову «defconf» — много раз тут писалось, хотите чтобы всё работало стабильно,
микротик настраивать надо с нуля, чистый, а не поверх пре-заводской настройки.

Увеличение числа IP-адресов в подсети на сервере DHCP

В этой статье описываются методы изменения количества IP-хостов на подсети на сервере динамической конфигурации хостов (DHCP).

Применяется к: Windows 10 — все выпуски, Windows Server 2012 R2
Исходный номер КБ: 255999

Симптомы

Вы пытаетесь расширить область действия на сервере DHCP. При изменении области в диалоговом окне Scope Properties вы получите следующую ошибку:

Диапазон IP был изменен, но пока не сохранен. При продолжении будут отбрасываются изменения. Продолжить?

Выбор «Да» или «Нет» этому сообщению не приводит к изменению существующей области.

Решение

В этой статье описываются методы, которые можно использовать для изменения количества IP-хостов в любой конкретной подсети. Охватываются следующие три метода:

  • Расширение области
  • Resubnetting
  • Superscoping

Расширение области

Предположим, что у вас уже есть область DHCP. В настоящее время Начните адрес и конечный адрес не включают все адреса для данной подсети. В этом случае, чтобы увеличить число адресов в области, можно расширить Начните адрес или конечный адрес в свойствах области.

В следующем примере показана сеть класса C со следующими настройками:

Адрес подсети: 192.168.1.0
Маска subnet: 255.255.255.0

В этом примере дается сеть из 254 хостов, которые занимают диапазон адресов от 192.168.1.1 до 192.168.1.254.

Созданная область имеет следующие свойства:

Начните адрес: 192.168.1.50
Конечный адрес: 192.168.1.150
Маска subnet: 255.255.255.0

Чтобы увеличить количество доступных клиентам адресов, можно изменить Начните адрес или конечный адрес соответственно 1 и 254.

В более ранних версиях DHCP необходимо было расширить Начните адрес или конечный адрес с приращением 32. Это больше не так, если вы работаете Windows NT 4.0 Пакет обновления 6 или более поздней.

Если область охвата уже охватывает весь диапазон и полностью используется, у вас есть только два других варианта: суперскобирование или повторное. Оба этих параметра требуют внесения архитектурных изменений в сеть.

Простое изменение параметров области DHCP не дает вам больше аренды. DHCP выполняется поверх архитектуры сетевой подсети и может раздать адреса, как вы хотите. В первую очередь всегда относится к необходимости расширения диапазонов адресов как к упражнению по архитектуре подсети. После того как вы решите, какую архитектуру использовать, можно настроить DHCP, чтобы соответствовать вашему сетевому дизайну.

Resubnetting

Resubnetting — это рекомендуемая процедура для увеличения области DHCP, когда текущая область полностью потребляет текущую маску подсети. Этот метод требует изменения всех хостов и шлюзов подсетей. Если у вас есть диапазон адресов, где не было доступных хост-адресов, возможно, можно изменить маску подсети, чтобы включить большую долю хост-адресов. Однако для простого изменения маски подсети требуется:

  • Все маршрутизаторы и другие статически назначенные компьютеры будут перенастроены.
  • Все клиенты DHCP возобновили аренду, получив новые параметры.

Кроме того, все области или области DHCP сначала должны быть удалены, а затем повторно созданы с помощью новой подсети маски. Если вы не принимаете меры для предотвращения использования адресов лизинга, которые могут использовать другие клиенты, в этот период могут возникать дублирующиеся адреса. Несмотря на все вышеперечисленные оговорки, повторное открытие по-прежнему является рекомендуемой процедурой. Конфигурация повторной сети не создает дополнительных накладных расходов на маршрутизаторы или шлюзы подсети и сохраняет все хосты на одном и том же адресе трансляции.

В следующем примере показана истощенная подсеть со следующими настройками:

Адрес подсети: 192.168.1.0
Маска subnet: 255.255.255.0

Она дает сеть из 254 хостов с адресами от 192.168.1.1 до 1921.68.1.254.

В следующем примере показан результат при использовании параметра resubnetting:

Адрес подсети: 192.168.1.0
Маска subnet: 255.255.254.0

Теперь у вас есть сеть из 510 хостов с адресами от 192.168.0.1 до 192.168.1.254 (для области 192.168.0.0) или 256 вновь доступных адресов DHCP.

Superscoping

Superscoping (также именуемая мультисетью) может соответствовать вашим требованиям. Если вы не хотите изменять подсети существующей сети, можно добавить больше логических сетей в один и тот же физический провод. Этот метод создает дополнительные нагрузки на маршрутизатор или шлюз, настроенный с несколькими логическими подсетями, работающими в одном физическом порте. Дополнительная нагрузка может привести к снижению производительности сети. Для связи с хостами в одной логической подсети необходимо пройти через шлюз для связи с хостами другой логической подсети, несмотря на общий доступ к одному физическому проводу.

В следующем примере показана истощенная подсеть со следующими настройками:

Адрес подсети: 192.168.1.0
Маска subnet: 255.255.255.0

В следующем примере показаны результаты при использовании параметра superscoping:

Адрес подсети: 192.168.1.0 и 192.168.2.0
Маска subnet: 255.255.255.0

Теперь у вас две сети из 254 хостов (всего 508 хостов) с адресами от 192.168.1 до 192.168.168.1.254 или 254 новых доступных адресов DHCP.

После того как вы решите, какой вариант вы хотите использовать, вы можете выбрать соответствующую конфигурацию DHCP.

Если используется параметр resubnetting, необходимо удалить и повторно создать область DHCP с помощью новой маски подсети. Невозможно изменить только маску для определенной области.

Если вы обслуживаете существующие клиенты в пределах части этого диапазона, необходимо включить обнаружение конфликтов до тех пор, пока все клиенты не будут перенесены в новую область. Это действие требует от вас принятия следующих действий:

  1. Настройте интерфейс каждого подключенного маршрутизатора и измените IP-адрес подключенного интерфейса, его адрес подсети и маску подсети.
  2. Удалите текущую область DHCP.
  3. Создайте новую область DHCP с помощью новой маски подсети.
  4. Включить параметр Конфликтные ириски на сервере DHCP (установлено 1 или 2).
  5. Принудить клиентов DHCP возобновить аренду DHCP.
  6. Измените IP-адрес, подсетевую маску и/или шлюз по умолчанию на каждом статически настроенного хоста.

При использовании параметра superscoping необходимо совместно использовать множество областей. Создайте каждую область по отдельности, а затем создайте суперскоп для включения отдельных областей. Это действие требует от вас принятия следующих действий:

Как настроить DHCP на микротике

Для того, чтобы устройства в сети могли автоматически получать настройки, настроим DHCP сервер на микротике.

Для начала создадим новый бридж. Все порты, добавленные в этот бридж, будут раздавать ip адреса из назначенного пула.

В разделе Bridge создайте новый бридж, в поле name укажите удобное вам имя.

bridge mikrotik

Назначим адресацию данному бриджу. В разделе IP – Addresses создайте новый адрес и пропишите сеть (в примере 192.168.1.1/24, network 192.168.1.0), в поле interface выберите созданный ранее бридж.

addresses микротик

Укажите пул адресов, которые будут назначаться устройствам, подключающимся к вашей сети. Для этого откройте раздел IP – Pool и создайте новый пул: укажите его имя, а в строке addresses укажите диапазон выдаваемых адресов (192.168.1.2-192.168.1.253 в примере).

пул микротик

Создайте DHCP сервер. Откройте раздел IP – DHCP Server – DHCP и добавьте новый сервер. В поле Name задайте любое имя, в поле Interface выберите ваш бридж, в address pool – созданный пул адресов. В поле lease time пропишите время, на которое устройствам выдается ip адрес (по умолчанию 10 минут).

dhcp сервер на микротике

Перейдите на вторую вкладку Networks (IP – DHCP Server – Networks). Нажмите на плюс и укажите адрес вашей сети, шлюз, маску и при необходимости DNS-адреса.

network на микротике

Настройте NAT для созданного сервера. Откройте IP – Firewall – NAT, создайте новое правило. Во вкладке General в поле chain выберите srcnat, в Src.address пропишите адресацию вашей сети. Перейдите на вкладку Action и укажите в поле Actionmasquerade.

nat на микротике

Также вы можете быстро применить конфиг для настройки dhcp через New Terminal микротика (измените в конфиге адреса и названия интерфейсов на нужные вам):

/interface bridge add name=inet-bridge

/ip address add address=192.168.1.1/24 interface=inet-bridge network=192.168.1.0

/ip pool add name=inet-pool ranges=192.168.1.2-192.168.1.253

/ip dhcp-server add address-pool=inet-pool disabled=no interface=inet-bridge lease-time=10m name=inet-dhcp

/ip dhcp-server network add address=192.168.1.0/24 dns-server=8.8.8.8 gateway=192.168.1.1 netmask=24

/ip firewall nat add action=masquerade chain=srcnat src-address=192.168.1.0/24

Как зарезервировать ip адрес на dhcp сервере mikrotik

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-01

Всем привет! Сегодня продолжим настройку DHCP сервера и узнаем, как зарезервировать ip адрес в DHCP в Windows Server 2008R2. Для выполнения данных действий у вас уже должен быть установлен и настроен dhcp сервер. Под резервированием понимается, что когда клиентский компьютер получаем ip адрес, то при следующем запросе получения нового ip адреса, компьютеру снова будет выделен этот ip и никому другому. Это очень удобно, в ситуациях без статических адресов, в серверном сегменте. Давайте посмотрим как это делается.

Алгоритм настройки резервирования в DHCP

Давайте зайдем на клиентскую машину и посмотрим текущий ip адрес в центре управления сетями и видим, что полученный ip адрес 10.10.1.25

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-02

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-02

Посмотрим теперь на сервере DHCP в списке арендованные адреса и видим, нашего клиента

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-03

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-03

теперь давайте произведем настройку DHCP и Добавим к резервированию ip адрес, для этого щелкаем правым кликом по нужному клиенту и нажимаем Добавить к резервированию

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-04

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-04

Выскочит уведомление, что Аренда успешно преобразована в резервирование.

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-05

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-05

Как можете заметить теперь данный ip адрес появился в пункте резервирование

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-06

Как зарезервировать ip адрес в DHCP в Windows Server 2008R2-06

Для того, чтобы удалить резервирование, щелкните правым кликом по нему и нажмите Удалить

Как настроить постоянный IP адрес

Большинство из вас, работая с компьютером, планшетом, или смартфоном, не задумывается о том, какой IP адрес имеет ваше устройство. Вы просто подключились к сети и тонкости настроек сетевых параметров вас мало беспокоят. Тем-же из вас, кому нужно, чтобы другие подключались к вашему компьютеру, потребуется настроить его так, чтобы IP адрес не изменялся.

Например, у вас есть компьютер, файлы которого нужно расшарить через интернет, сетевой принтер, или, если вы захотели иметь доступ к Удаленному рабочему столу своего домашнего компьютера, да и много для чего еще — для всего этого нужно, чтоб IP адрес компьютера, к которому будет осуществляться подключение, не изменялся.

Есть два варианта, как сделать IP адрес компьютера постоянным — это настроить его статически на компьютере, или более удобный вариант — настроить резервирование IP адреса на DHCP сервере.

Зарезервировать IP адрес на DHCP сервере

Самым удобным и рекомендуемым способом сохранить за вашим компьютером постоянный IP адрес, является резервирование на DHCP сервере. DHCP, если дословено переводить — это протокол динамической конфигурации узлов сети, Dynamic Host Configuration Protocol, согласно которому все сетевые устройства могут запрашивать и получать настройки сети, без необходимости привлечения пользователя к этому процессу. Даже если вы и не знали что такое DHCP, наверняка с ним сталкивались — все домашние роутеры имеют настроенный DHCP сервер. Всякий раз, когда вы подключаетесь к WiFi точке доступа, ваш смартфон, или ноутбук применяют сетевые параметры, полученные именно с DHCP сервера, которым чаще всего и является роутер.

В виду того, что вы в любом случае уже подключены к сети с использованием DHCP, имеет смысл на DHCP серере настроить резерирование, суть которого заключается в заполнении таблицы соответствия MAC адресов и IP адресов. Всякий раз, когда будет подключаться сетевое устройство, с MAC адресом, для которого в таблице соответствий прописан IP адрес, будет возвращен именно этот IP адрес. Для других сетевых устройств данный адрес будет не доступен (со стороны DHCP сервера).

Cогласно описания протокола DHCP, таблица соответствий может содержать гораздо больше информации, чем просто IP адреса компьютеров, но, в рамках данной статьи будет рассмотрена частность, касающаяся сохранения за компьютером постоянного IP адреса.

Не смотря на то, что интерфейс администрирования маршрутизаторов разных производителей отличается, суть настройки остается одинаковая:

Подключитесь к веб интерфейсу настройки вашего роутера. Если вы не помните какой у него адрес, посмотрите в информации о сетевом соединении, шлюз по умолчанию. Сделать вы это можете из командной строки выполнив команду ipconfig

Также вы можете узнать эту-же информацию через Центр управления сетями и общим доступом:

Теперь, в браузере откройте адрес роутера, введите логин и пароль. Если вы не меняли заводской пароль, то попробуйте комбинацию логин/пароль: admin/admin, или посмотрите в руководстве пользователя.

Найдите пункт меню, который ведет к настройкам DHCP сервера. В маршрутизаторах Linksys данный пункт находится в разделе Basic settings.

Как видно на изображении выше, для того, чтоб добавить резервацию, следует нажать кнопку DHCP Reservation, после чего откроется окно, настройки резервации:

Здесь перечислен список устройств, которые уже подключались к роутеру. Каждое устройство, которому установлен чекбокс, после нажатия кнопки Add Clients будет добавлено в список резервации. Если устройства в списке нет, ниже находится поле, в котором вы можете ввести информацию вручную.

Если вашего устройства нет среди известных роутеру устройств, вам нужно узнать MAC адрес вашего компьютера. Делается это аналогично тому, как мы узнавали Шлюз по умолчанию, а именно выполнив команду ipconfig, или через Центр управления сетями и общим доступом. Называется он Физический адрес:

После добавления, все зарезервированные устройства будут перечислены в разделе “Clients Already Reserved”.

Вот и все. После добавления вашего устройства и сохранения изменений, IP адрес будет закреплен за вашим устройством и вы можете быть уверены в том, что ваш компьютер, или другой девайс будет доступен все время.

Статический IP адрес

Как вариант, если у вас старый роутер и в нем нет возможности нстроить резервирование IP адресов, или вы не используете DHCP, можно настроить статический IP адрес внутри самой операцонной системы.

Откройте Центр управления сетями и общим доступом — Настройка параметров адаптера — Нажмите правой кнопкой мыши адаптер, который нужно настроить, в контекстном меню выберите пункт Свойства.

Выберите протокол IPv4 и нажмите кнопку Свойства:

В открывшемся окне переведите радио переключатель в положение «Использовать следующий IP-адрес»:

Рейтинг
( Пока оценок нет )
Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:

Adblock
detector